Dashboard Loading Failure

Incident Report for Offstreet

Postmortem

What happened

A recent deployment introduced a configuration issue that impacted a subset of our services. Normally, our deployment process automatically rolls back when issues are detected. In this case, the affected services didn’t fail completely on startup, so the rollback wasn’t triggered.

Impact

  • Dashboard: Unavailable during the incident.
  • Portal: Some users were unable to complete registrations for new events. Other functionality continued to work as expected.

How we resolved it

We identified the problem and manually rolled back the deployment, which restored full functionality.

What we’re doing to prevent this

We’ve identified why the issue didn’t trigger an automatic rollback, and we’re planning improvements to our startup checks. These changes will ensure immediate rollback in the future.

Posted Apr 24, 2025 - 08:30 CST

Resolved

Earlier today, we experienced a brief issue that impacted access to the Offstreet dashboard. The incident was flagged at 8:08 AM and resolved by 8:13 AM, during which time users were unable to access the dashboard interface.

We apologize for any inconvenience this may have caused. Our team responded immediately and restored access within five minutes. The system is now fully operational, and we are continuing to monitor performance.

Thank you for your patience, and please don’t hesitate to reach out if you have any questions or concerns.
Posted Apr 24, 2025 - 08:00 CST